Client portal

Lib.php is corrupted.

 July 1, 2018     6 Comments

Upon upgrading to Clientexec 5.8.0, if you recieve an error message stating Lib.php is corrupt (/home/user/public_html/clientexec/library/CE/Lib.php is corrupted.), this means you are using an older version of the ionCube Loader then we support.

Please ensure you are using the latest ionCube Loader, and this will fix the issue.

How helpful was this article to you?

6 Comments

icon
Celluloid Solutions
July 2, 2018

I am using BlueHost and they do not have latest ionCube. What to do? My clientExec installation has been stalled. Cannot access anymore.

icon
Matt Grandy
July 2, 2018

@Celluloid Solutions Can you open a ticket and ask them to add support for at least 10.1?

If they won't support it, simply re-upload the 5.7.1 files: https://s3.amazonaws.com/clientexec/clientexec_5_7_1_ioncube.zip

icon
Damon Burton
July 10, 2018

Is this the same problem if it says "install.php is corrupted" when upgrading?

icon
Matt Grandy
July 11, 2018

@Damon Yes, same problem. You need to be running the latest version of the ionCube Loader.

icon
EXEPLORE, LLC
July 16, 2018

I ran into this same issue. I re-uploaded 5.7.1, made sure my host upgraded my account for ionCube Installation 10.1, performed the update from within my ClientExec dashboard. Successful! Now running 5.8.1.

icon
James Mullen
July 22, 2018

It would've been VERY helpful had the update process warned that the upgrade would completely break your install of CE if you don't have ioncube 10.1 loader installed and you will have to spend a lot of time fixing it and, if you don't have time to fix it now, don't upgrade!

Posting has been disabled.