Malformed communication packet or Error Could not connect to the database

 November 4, 2020     0 Comments

After applying the November 3rd 2020 MariaDB upgrade, certain PHP versions will fail to work and report the following error messages:

SQLSTATE[HY000]: General error: 1835 Malformed communication packet

OR

Critical Error Could not connect to the database

Until a fix is released from MariaDB, to resolve these errors, you must either update to PHP 7.3 or downgrade your MariaDB version.

More information on this bug can be tracked at https://jira.mariadb.org/browse/MDEV-24121

How helpful was this article to you?

Posting has been disabled.